froyo は java 1.5

ubuntu-10.10 で froyo をビルドしようとしたら java 1.5 が必要なことがわかった。
http://d.hatena.ne.jp/hrsth/20100116/1263651661
を参考に

# /etc/apt/source.list

deb http://us.archive.ubuntu.com/ubuntu/ jaunty multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty multiverse

deb http://us.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse

を追加し

> sudo apt-get update
> sudo apt-get install sun-java5-jdk

> sudo update-alternatives --config java
> sudo update-alternatives --config javac

コンパイルは始まった。beagleboard がサポートされていない?のか TARGET_PRODUCT=beagleboard はエラーになった。しかたがないので generic でビルドを開始する。kernel というディレクトリがないのが気になる。